Major Outage
Incident Report for United Baristas
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 08:05 BST
Identified
United Baristas (and half the internet) is down following an outage at a major internet service.
Posted Jun 21, 2022 - 07:58 BST
This incident affected: United Baristas (Articles, Equipment).