Layout issues on select United Baristas Jobs pages
Incident Report for United Baristas
Resolved
Update pushed. We're making lots of small updates at present and will continue to try and avoid glitches such as this. You can find out more about the work in progress at https://updates.unitedbaristas.com/. Thanks for your patience.
Posted May 13, 2022 - 10:39 BST
Identified
Some pages on United Baristas Jobs are wonky following an update. Fix being pushed.
Posted May 13, 2022 - 10:07 BST